[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20040414 changes



seth vidal wrote:
This package has a really odd dependency problem, trying a `yum update`
fails with an error, 'Package libselinux needs glibc >, this is not
availible.'  Given that I'm fairly certain an unversioned release of
glibc isn't going to happen, I'm assuming this is a packaging problem...




More likely a yum problem since rpm reports more sensibly:


   # rpm -Fvh libselinux-1.11-1.i386.rpm
   error: Failed dependencies:
       glibc > 2.3.4 is needed by libselinux-1.11-1



how is this a yum problem? You have a package that requires something
that doesn't exist. And that's a yum problem?

No, the yum problem is that it didn't report the version number of glibc required. Compare the above to this:


[root starlifter headers]# yum update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.91 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package libselinux needs glibc >, this is not available.
[root starlifter headers]#

Nathan.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]