[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ALSA in a 2.6 world



On Friday 16 April 2004 00:26, Warren Togami wrote:
> Florin Andrei wrote:
> > On Thu, 2004-04-15 at 19:36, Charles R. Anderson wrote:
> >>On Thu, Apr 15, 2004 at 07:29:38PM -0700, Florin Andrei wrote:
> >>>Sure, one could compile a newer kernel, but that way the Red Hat changes
> >>>to the kernel (which are often good for demanding apps such as digital
> >>>recorders) will be lost.
> >>The stated goals of Fedora are to stay as close to mainline upstream
> >>as possible.  This includes the kernel.
> > [the FC1 latest kernel is] 2.4.22-1.2174.nptlsmp
> > The latest 2.4 version of the Linux kernel is:              2.4.26

> > That doesn't seem to me like any kind of closeness to the alleged
> > "goals". ;-)
> Seriously though, in 99% cases the only way you will get anything into
> the Fedora kernel is to convince upstream to include it.  Upstream
> inclusion means that a LOT more users and developers will be using and
> supporting it than Red Hat or Fedora alone.  That is a significant
> advantage that should not be overlooked.

Everbody is missing the point.  The point is this:
FC2 is released, possibly with kernel 2.6.6.

A month later, 2.6.7 is released, incorporating security fixes as well as new 
features, like a new ALSA that better supports, say, Echo Layla24 (the 
current ALSA support is experimental).  (Layla24, BTW, is an 8 input 10 
output high end 24bit /96ksps audio interface (not a sound card, since the 
card in the PC is just a special digital bus interface to an external 1U rack 
mount box) that has killer professional specifications, but has not been very 
well supported as yet).  The 2.6.7 release might also have, say, a major ATM 
bug fixed in the ForeRunner HE622 driver (listed as unsupported) (I use an 
HE622 here). The linux-atm project does not release separate patch tarballs, 
but only releases through 'upstream' kernels.

Traditional Red Hat and FC1 backported the security fix only and kept the 
kernel version the same (in this example, that would lose the improved 
Layla24 support as well as the HE622 bugfix that are in the new UPSTREAM 
kernel).  

The question before the group becomes: "Will FC2 release an errata for a 
patched 2.6.6 or will FC2 release a 2.6.7 that has the security fix AND the 
updated drivers/features/whatnot, along with any updated packages that might 
be necessary for the new kernel?"  We know the previous policy; we want to 
better understand the new policy.  Just saying that the goal is to be closer 
to upstream doesn't directly address this issue, IMHO.  To me, the current 
statement simply means that the Fedora Core kernel, at the time of release, 
will be as close as possible to the upstream kernel, at the time of the 
Fedora prerelease freeze.  Errata kernels are not mentioned, AFAICT, unless I 
am very much misreading the statement.
-- 
Lamar Owen
Director of Information Technology
Pisgah Astronomical Research Institute
1 PARI Drive
Rosman, NC  28772
(828)862-5554
www.pari.edu



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]