[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Requiring perl(:MODULE_COMPAT_$version)



Here is some spec-file magic that might be useful to others..

Modified Files:
	foomatic.spec 
Log Message:
* Mon Apr 19 2004 Tim Waugh <twaugh redhat com> 3.0.1-3
- Require appropriate perl(:MODULE_COMPAT_...) symbol (bug #121131).


Index: foomatic.spec
===================================================================
RCS file: /cvs/pkgs/rpms/foomatic/foomatic.spec,v
retrieving revision 1.85
retrieving revision 1.86
diff -u -r1.85 -r1.86
--- foomatic.spec	10 Mar 2004 11:44:40 -0000	1.85
+++ foomatic.spec	19 Apr 2004 11:02:35 -0000	1.86
@@ -6,7 +6,7 @@
 Summary: Foomatic printer database.
 Name:		foomatic
 Version:	3.0.1
-Release: 2
+Release: 3
 License:	GPL
 Group: System Environment/Libraries
 
@@ -53,6 +53,7 @@
 BuildRequires:	perl >= 3:5.8.1
 BuildRequires:	libxml2-devel
 Requires:	perl >= 3:5.8.1
+Requires:	%(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
 BuildRoot:	%_tmppath/%name-%version-%release-root
 Provides:	perl(Foomatic::GrovePath)
 Requires:	perl-libxml-enno >= 1.02
@@ -248,6 +249,9 @@
 %{_mandir}/*/*
 
 %changelog
+* Mon Apr 19 2004 Tim Waugh <twaugh redhat com> 3.0.1-3
+- Require appropriate perl(:MODULE_COMPAT_...) symbol (bug #121131).
+
 * Wed Mar 10 2004 Tim Waugh <twaugh redhat com>
 - Fix deprecated cast-as-lvalues.
 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]