[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: postfix-2.1



On Fri, Apr 23, 2004, Tom Diehl <tdiehl rogueind com> wrote:
> On Fri, 23 Apr 2004, Chuck Mead wrote:
> 
> > Florin Andrei wrote:
> > | Is i too late to include Postfix-2.1 in FC2?
> > | That "inspect mail before it is queued" thing looks really nice. ;-)
> > |
> > 
> > Is anyone working on an rpm for this that includes TLS? Though I suppose
> > we could always wait for Simon Mudd to finish his.
> 
> Simon is working on it although it would appear he is having some problems
> getting the srpm into a state where it will build on all of the supported
> platforms. Currently I cannot get it to build on RHEL3 and I know of st least
> 2 other people having the same problem. 1 is on whitebox and the other I do
> not know what platform/distro he is using. I really feel this is just a
> variable not getting set properly as Simon has indicated it builds on
> whitebox for him. I expect to see an announcment/request for testing from
> him soon. IIRC the postfix-RC test rpms had TLS included.

I grabbed his latest 2.1-RC4 RPM packages and adapted it to FC1 and the
release 2.1pl0.

The big problem getting it to compile was with embedded %doc and
%install strings that silently caused rpmbuild to fail with a strange
error message. Deleting the % sign from the comments fixed the problem.

It appears that there are some patches included that are only
appropriate for 2.0 and not 2.1. Atleast they give a ton of patching
errors if you try to use them. The TLS patches are one of them.

I finally did get a package built and I'm playing around with it now,
but the lack of TLS is a problem for me right now. I was going to spend
some more time this weekend figuring out what needs to be done to get
Postfix 2.1 with TLS support. (I haven't been keeping up)

JE



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]