[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: LVM snapshot



On Thu, 12 Aug 2004 02:00, Russell Coker <russell coker com au> wrote:
> lvcreate -s -n snap -l 10 /dev/V0/fc2
>
> /dev/V0/fc2 is the root file system for my FC2 machine.  I ran the above
> command to make a snapshot of it named /dev/mapper/snap and now all access
> to the root FS is blocking.  I had "less" running before this and I can
> still scroll.  I expect that "-l 10" is enough as my PE size is 16M and I
> don't expect to make more than 160M of changes before the backup is
> complete.
>
> Did I do something wrong or is this an indication of a kernel bug in LVM?

I just tried rebooted that machine.  The LVM setup seems mangled and it 
doesn't boot successfully.

On #lvm on irc.freenode.net I was told that the kernels in Fedora don't yet 
support snap-shot which is the cause of the problem.  I have been told that 
the lvm utility programs in FC3T1 correctly detect this (and presumably don't 
break the system).

-- 
http://www.coker.com.au/selinux/   My NSA Security Enhanced Linux packages
http://www.coker.com.au/bonnie++/  Bonnie++ hard drive benchmark
http://www.coker.com.au/postal/    Postal SMTP/POP benchmark
http://www.coker.com.au/~russell/  My home page



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]