[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XFree86 4.3.0-56 EPIA test results



On Tue, Feb 17, 2004 at 12:52:16AM -0500, Mike A. Harris wrote:
> -57 is now ready, and includes the via_dri.so module properly.  
> Please test the 4.3.0-57 package out using the included via_drv.o 
> 2D driver, via_dri.so 3D driver, and ensuring you're not using 
> 3rd party bits, so the testing is clean.
Just tested with -57 and the good news is that DRI works just fine (after
compiling the necessary module, and accepting that menus in tuxracer are
brown, the game itself was fine). 

Xv initially worked ok (with zero 3rd party components including the dri
module) until I did a power-off (rebooting a new kernel wasn't enough).
After that it had the same problems as -56 (Xv stuff looking completely
wrong).

Reverting to the via_drv binary I mentioned in the original report made
things work, even when switching back to the -57 via_drv.o So there seems to
be a "Make Xv work" register that isn't being set by the driver, but it
doesn't get set the wrong way either :-) Reported as #116027.

Sure would be nice to get the dri code in the 2.6 kernel btw., the
drivers/char/drm parts of
http://epia.kalf.org/gryle_patches/via-v4l-1.4a-drm.patch.gz patch just fine
into 2.6.2-1.85 (the drivers/media/video stuff that uses e.g. floating point
can be left out, which is what I did for this iteration of testing)

-- 
Pekka Pietikainen




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]