[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

3Dfx DRI support, Glide3, and you



Are there any 3Dfx users out there still, using Voodoo 3/4/5 or
Banshee, who are interested in DRI support (3D acceleration)  
continuing to be part of the distribution?

What a perfect time to volunteer!

Essentially, Glide3 source code is rather insane, compiler picky, 
and gcc barfs on it nowadays.  It was unmaintained upstream for 2 
years, but we kept it because "it worked".  Now, "it doesn't 
work", and is a zero-priority level package basically.

I hate to drop hardware support, but continuing to maintain an
aging unsupported package like this is a waste of resources that
I could be much better spending, hacking on more relevant stuff.

I really don't plan on spending any time on this rather obsolete
package anymore however if nobody upstream or out in the
community is interested in keeping it alive, and I'm definitely
not interested in becoming the upstream maintainer.  That said, 
there are upstream people still working on Glide, however there 
are some "issues" with switching to the new code, including the 
fact it's never been widely deployed or tested yet.

If someone is interested in volunteering to make this compile
again, in Fedora Core 1 and 2, please contact me back, or hop
into IRC.  My preference is to allow others to get involved 
rather than just dropping something that some people out there 
are bound to still use, and would like to see it remain in the 
distribution.

Thanks in advance.




-- 
Mike A. Harris     ftp://people.redhat.com/mharris
OS Systems Engineer - XFree86 maintainer - Red Hat




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]