[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help Needed: Missing Obsoletes cause upgrade trouble



On Apr 23, 2004, Thorsten Leemhuis <fedora leemhuis info> wrote:

> Am Fr, den 23.04.2004 schrieb Michael Schwendt um 16:13:
>> On Fri, 23 Apr 2004 02:22:56 +0200, Michael Schwendt wrote:
> [...]
>> >   alsa-driver ./. dev, MAKEDEV
>> >   alsa-lib, alsa-utils, all of alsa* because 1.0.4 > 1.0.3a!
>> 
>> Dangerous. In particular "alsa-driver", which contains many /dev files.

> What can I (as alsa-packager for fedora.us) do to solve this problem?
> Any hints?

IIRC the only conflict is with MAKEDEV.  How about getting your
alsa-driver to Require: the file provided by MAKEDEV, and split that
file out into a separate package, say alsa-driver-MAKEDEV?

-- 
Alexandre Oliva             http://www.ic.unicamp.br/~oliva/
Red Hat Compiler Engineer   aoliva {redhat com, gcc.gnu.org}
Free Software Evangelist  oliva {lsd ic unicamp br, gnu.org}



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]