[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: gnupg newpg gpgme gpgme03 cryptplug isuses



Dennis Gilmore (dennis ausil us) said: 
> Recently the version of libgcrypt was increased  to 1.1.94  as a result of 
> this newpg would not build against the newer libgcrypt  i sent an email to 
> gcrypt-devel list and this is what i got back 
> 
> <quote>
> Don't build newpg at all.  It has been superseded by gnupg-1.9.x .
> 
> You would need an old libgcrypt < 1.1.42 to build it.  The configure
> sscript was not able to detect newer versions with a changed API. 
> </quote>
> 
> we have a problem here seems we no longer need newpg  but we need things it 
> provides  for gpgme gpgme03 cryptplug  gpa  kgpg (which doesnt complain so 
> much  just says its not there)   to get these things it provides  we need to 
> go to the newer gnupg  or we need to revert back to the older libgcrypt.
> 
> being so late in the cycle i dont know which would be best.  so i thought id 
> ask before filling a bug against something.  it does need to be fixed before 
> final is out  as people will complain if they cant decrypt email in kmail or 
> mutt gpa doesnt work  etc. i think we should probably go back to the old 
> version of libgcrypt

For a third-party package we don't ship? It's probably not going to
happen at this point. Note that, for example, mutt with gnupg will
work pretty much the same as it normally does in core - it doesn't
require libgcrypt. 

libgcrypt was updated for a package we do ship (cryptsetup for dm-crypt).

Bill



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]