[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC 2 - RPM virtual provides on PIE broken (odd conflicts/triggers)



On Fri, 2004-05-21 at 07:51 -0400, Paul Nasrat wrote:
> Some people will be experiencing  odd behaviour due to the way rpm adds library provides - this can causes any PIE executables to be added as 
> 
> Provides: $(basename /path/to/foo)
> 
> A name level provides matches all EVR so known issues - spurious conflicts,
> misfired triggers, etc occur. As more things in rawhide get built
> -fPIE it's something to be aware of untill an errata can be issued.

'an erratum' HTH.

Is there a way to disable the automatic Provides, other than just
disabling PIE? If I build ppp, it suddenly starts providing pppd, which
it never did before -- and initscripts has a Conflicts: for pppd <
2.3.9. (which should presumably be ppp < 2.3.9; BZ #124386)

-- 
dwmw2




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]