[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: A true package manager.



Ricardo Veguilla wrote:
On Sat, 2004-11-06 at 23:04 +0100, Iago Rubio wrote:
  
On Sat, 2004-11-06 at 13:22, Jos Vos wrote:
    
On Sat, Nov 06, 2004 at 01:10:09PM +0100, Iago Rubio wrote:

      
I don't think yum should merge with up2date. Yum bypasses up2date
functionality right now and frankly I don't use up2date ever because
it's still buggy (On my FC1 and FC2 systems).
        
What are the bugs you encounter? 
      
Mostly hangs when downloading packages.
    

Yep, it also happened to me, many times up2date was just unresponsive
(i.e. it appeared to be hanged). 

  
I don't know how it works in xoslinux, but in my fedora boxes I don't
use it because it used to fail, and also because I'm happy with yum.
    

I don't know if or how up2date was improved post FC2 but I'm running
rawhide and up2date has been very reliable. I was able to upgrade my
system without problems with up2date during the early yum 2.1.x unstable
periods.    


  
I'd really like to interface the rhn applet with yum, or at least to
make it configurable so you could launch your preferred update command -
in my case `xterm -e yum update` :)
        
What do you mean with "interface the rhn applet with yum"?  Rhn-applet
works fine with yum repositories.
      
I mean one "Launch Yum" button instead of the "Launch up2date" button on
the rhn notification tool dialog :)

    

You can try this[1]:

GYUM: Graphical User Interface for YUM
http://fedoranews.org/tchung/gyum/
HOWTO build GYUM Alert Icon (yum-applet) [2]
http://fedoranews.org/tchung/yum-applet/
  
Nice tool this gyum.
It has features very welcome, listing all the packages, removing one by one, and so on...
I'm not sure, but I don't think it will work with the latest yum
(2.1.x).

  
I've compiled it on FC3 test 3, and is working perfectly with the latest version of yum.
[1] I did, and now I appreciate up2date even more.
[2] This is a partial hacked version of the rhn-applet. IIRC, you can
instll or use both (rhn-applet and yum-applet) at the same time.
  

And here is working better then up2date, because i was updating almost 1 by 1 the packages because up2date hang up if i
chosed all, or a big number, With gyum until now i had no problem.

Nando


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]