[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problems mounting digital camera on FC3



I posted this to fedora-list a couple of days ago, but have not had any responses. Given past successes with getting problems solved there, I am going to assume that either noone else has this problem, or no one has any ideas what is different, and how to get it to work.

That being said, I have a Nikon D70 digital camera that I am trying to mount on a freshly installed FC3. When I plug the camera in, and turn it on, I get the following messages in /var/log/messages (editted for brevity):

Nov 9 14:31:14 localhost kernel: usb 2-1: new full speed USB device using address 8
Nov 9 14:31:14 localhost kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Nov 9 14:31:14 localhost kernel: Vendor: NIKON Model: D70 Rev: 1.01
Nov 9 14:31:14 localhost kernel: Type: Direct-Access ANSI SCSI revision: 02
Nov 9 14:31:18 localhost kernel: sda: Spinning up disk......ready
Nov 9 14:31:18 localhost kernel: SCSI device sda: 3999745 512-byte hdwr sectors (2048 MB)
Nov 9 14:31:18 localhost kernel: sda: Write Protect is off
Nov 9 14:31:18 localhost kernel: sda: assuming drive cache: write through
Nov 9 14:31:18 localhost kernel: sda:end_request: I/O error, dev sda, sector 3999744
Nov 9 14:31:18 localhost kernel: Buffer I/O error on device sda, logical block 3999744
Nov 9 14:31:18 localhost kernel: end_request: I/O error, dev sda, sector 3999744
Nov 9 14:31:18 localhost kernel: Buffer I/O error on device sda, logical block 3999744
Nov 9 14:31:18 localhost kernel: sda1
Nov 9 14:31:18 localhost kernel: Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
Nov 9 14:31:18 localhost scsi.agent[20673]: disk at /devices/pci0000:00/0000:00:1f.4/usb2/2-1/2-1:1.0/host3/3:0:0:0
Nov 9 14:31:19 localhost kernel: end_request: I/O error, dev sda, sector 63
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 0
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 1
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 2
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 3
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 4
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 5
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 6
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 7
Nov 9 14:31:19 localhost kernel: end_request: I/O error, dev sda, sector 575
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 512
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 513
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 514
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 515
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 516
Nov 9 14:31:19 localhost kernel: Buffer I/O error on device sda1, logical block 517
....


This continues for some while.

If I were just looking at this, I might assume that the CF card (actually, a microdrive) was improperly formatted, or that there were other problems reading the card.

However, using the same exact computer, but booting into a stock FC1, I have no problems (although I have to mount /dev/sda1 myself).

Note, I have not been able to successfully mount the camera in either FC2 or FC3, suggesting a problem with the 2.6 kernel (could be a red herring, but...).

Any recommendations on how to proceed or test would be greatly appreciated. I can provide additional information, as requested (eg, FC1 /var/log/messages, lsmod, etc).

Tonight, I am going to try and build a stock 2.6 kernel, and see if that helps, hinders, or continues with the same results.

TIA

--
Keven Ring               | "Oh no,  Not Again..."
The MITRE Corporation    |   Bowl of Petunias -
7515 Colshire Drive      |   The Hitchhikers Guide to the Galaxy
McLean VA 22102-7508     |
PH: (703)883-7026        |




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]