[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: compat (libgal2 gtkhtml3) packages for Fedora Extras



On Sun, 2004-11-14 at 08:18 +0000, Michael A. Peters wrote:
> I discovered I needed these two packages to get gnomesword2 to build in  
> FC3.

Wouldn't be easier to compile gnomesword2 against the newer libs? 

> I have since encountered other people with other software that needs  
> the older shared libraries, such as monodoc.

Yes, but since the Novel/Ximian guys like to develop against the stable
releases (more specifically, against the libraries shipped with the
stable release), monodoc will probably use the newer libs now that FC3
was released.

> Attached are spec files that are based on the FC2 spec files for those  
> packages - it would great if *someone* who is a Fedora Extras would be  
> willing to adopt them for Fedora Extras since FC3 ships versions that  
> are too new for some software. All the build/install dependencies they  
> need are already in FC2 (well, the compat-gtkhtml3 requires the compat- 
> libgal2, but ...)

In general, I don't think adding compatibilty libraries should be done
unless there is no other alternative. The effort required to mantained
them, etc will probably be better employed porting the applications to
the new libraries.

Regards,
-- 
Ricardo Veguilla <veguilla hpcf upr edu>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]