[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: prelink issues



On Fri, 2004-11-19 at 15:59 -0500, Jakub Jelinek wrote:
> On Fri, Nov 19, 2004 at 03:10:19PM -0500, Colin Walters wrote:
> > The hal/dbus issue appears to be reproducible on FC3+updates, but not
> > with stock FC3.  My guess is that letting prelink run on stock FC3 might
> > cause this too, I'm about to check that.
> 
> If you are able to reproduce it, please create a tarball containing
> the binary and all its dependencies (do ldd on the binary and tar
> everything up).

I just tried a fresh FC3 install, ran prelink -a, didn't have any
problem.  I then installed all the FC3 updates, logged out and logged
back in, no problem.  (Except the latest FC3 kernel fails to boot on my
machine, but that's another bug)

> Even if packages misbehave when prelinked and don't when not prelinked,
> there is no guarantee prelink is at fault.

Right, I understand that.

> Prelink changes the memory layout of the application, so if certain
> library or binary e.g. has memory management bugs, it can show up
> only with certain memory layouts and not with others.

Ok.  I'm a bit baffled as to why this should only show up now if that's
what's happening though.  I've gotten about 5-6 reports of this against
eggucups upstream just in the last few days.

> Anyway, if you have a reproducer and tar up the binary, all libraries
> and whatever else is necessary for reproduction, that goes away
> if you unprelink the binary or its libraries, I'll certainly look at
> it.

Will do.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]