[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum broken = no testing



On Fri, 2004-11-26 at 08:40 +0100, Ralf Corsepius wrote:
> On Fri, 2004-11-26 at 02:02 -0500, seth vidal wrote:
> > > Well...  it'd be much easier for a user running the current python to 
> > > get a new yum RPM to be able to fix their system than to go through the 
> > > dependency fun that is upgrading python when something like yum is 
> > > "busted".  I am OK with this not going into the upstream yum package, 
> > > but it might be worth adding to our packages for the time being....
> > 
> > so by that argument, if gtk had an api break then mozilla should work
> > around it, rather than making the fix occur in gtk?
> Yes. That's how things work in real world. 

No.  No, it is not.  In the toy development system world, maybe.  In the
real world, major system libraries like GTK and Python remain ABI and
API stable.  If a breakage does occur, the breakage is separated into a
new major version allowing both versions to be installed.  GTK in fact
makes that guarantee, and that is one of its biggest selling points.

> 
> As a developer you spend a significant time to work around bugs, API
> changes and things which don't behave as you expect them to do.

That's not an excuse.  That's a description of all that's wrong with the
world from a programmer's perspective.  ;-)  Bugs are going to happen,
but there is absolutely *no* reason for an API/ABI breakage, ever,
without at least versioning the break correctly.

That said, this is Rawhide, breakages are expected, especially so soon
after the repository was opened for changes.

> 
> Ralf
> 
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]