[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Reopen a request for gpgme in Core



On Thu, Jan 06, 2005 at 12:04:48PM -0600, Rex Dieter wrote:
> Michael Schwendt wrote:
> 
> > GPGME 1.0 and dependencies are in the fedora.us submission list
> > already. Bugs: 2178 -> 2179 -> 2180 <- 2185
> > 
> > Among the things to examine are:
> > 
> >  * Dependencies on GPGME 0.4.x: gpa, elmo
>  >  * How are gpa and elmo affected by an upgrade from gpgme 0.4.x?
> 
> AFAIK, gpgme-1.0.0 is binary/api compatible with gpgme-0.4.x (I think 
> the 0.4.x versions were simply used to denote preleases before 1.0 was done)
> 
gpgme-0.4.x releases aren't entirely ABI/API compatible.  So it may
depend on the version of 0.4 that they were designed for.  Notably, 0.4.0
and 0.4.1 had some major API revisions.  While porting sylpheed from 0.3 the
documented changes indicated I would need 0.4.5 or above.  At that point the
ABI changed subtly as the library defaulted to being compiled with large
file support.  Requires a change to configure.in if you're using certain
functions.

Also, there are many deprecated functions and structures that may still be
present in the code that the gpgme authors aren't guaranteeing will be
available through the entire 1.0.x release cycle.

Moving from 0.4 to 1.0 will be much easier than moving from 0.3 to 1.0,
though as the changes are small and well documented in the info pages and
the NEWS file.

-Toshio


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]