[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Upgrading readline



On Thu, Dec 09, 2004 at 02:33:19AM +0800, Jeff Pitman wrote:

> On Thursday 09 December 2004 02:14, Bill Nottingham wrote:
> > > For upgrading readline to a new major release (in Fedora
> > > development), do I need to provide a readline4 package, or is it
> > > sufficient to just rebuild the packages that depend on it?
> >
> > A compat library may be nice, considering the number of apps that
> > link against it.
> 
> Check ABI compat within pkg first.  Eg, you can link python 1.5 against 
> db4 cuz db4 has db1-ish stuff still.  Reduction of compat madness is 
> optimal.

No, the soname has definitely changed incompatibly.  I'll have a go at
making a readline43 package.

Tim.
*/

Attachment: pgp00046.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]