[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum remove openoffice.org-libs ... Problem



[root one ~]# rpm -q -a | grep -i openoffice
openoffice.org-i18n-1.1.2-11.5.fc3
openoffice.org-1.1.2-11.5.fc3
openoffice.org-libs-1.1.2-11.5.fc3

[root one ~]# rpm -e --test openoffice.org-libs
erreur: Dépendances requises:
        libcomphelp3gcc3.so est nécessaire pour (déjà installé) openoffice.org-1.1.2-11.5.fc3.i386
(...)
[root one ~]# rpm -e --test openoffice.org

erreur: Dépendances requises:
        openoffice.org = 1.1.2-11.5.fc3 est nécessaire pour (déjà installé) openoffice.org-i18n-1.1.2-11.5.fc3.i386
        openoffice.org = 1.1.2-11.5.fc3 est nécessaire pour (déjà installé) openoffice.org-libs-1.1.2-11.5.fc3.i386


So, removing openoffice.org-libs will remove openoffice.org and openoffice.org-i18n .


 [root one ~]# yum remove openoffice.org-libs
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package openoffice.org-libs.i386 0:1.1.2-11.5.fc3 set to be erased
--> Running transaction check
Setting up Repo:  updates-testing
repomd.xml                100% |=========================|  951 B    00:00
Setting up Repo:  Base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 6.5 kB    00:00
MD Read   : ################################################## 12/12
updates-te: ################################################## 12/12
primary.xml.gz            100% |=========================| 619 kB    00:00
MD Read   : ################################################## 1653/1653
Base      : ################################################## 1652/1652
primary.xml.gz            100% |=========================| 182 kB    00:00
MD Read   : ################################################## 361/361
updates   : ################################################## 361/361
--> Processing Dependency: openoffice.org-libs = 1.1.2-11.5.fc3 for package: openoffice.org
--> Processing Dependency: libsb645li.so for package: openoffice.org
--> Processing Dependency: libsvl645li.so for package: openoffice.org
--> Processing Dependency: libucbhelper2gcc3.so for package: openoffice.org
--> Processing Dependency: libsal.so.3(UDK_3.1) for package: openoffice.org
--> Processing Dependency: libcppuhelpergcc3.so.3 for package: openoffice.org
--> Processing Dependency: libtl645li.so for package: openoffice.org
--> Processing Dependency: libspa645li.so for package: openoffice.org
--> Processing Dependency: libutl645li.so for package: openoffice.org
--> Processing Dependency: libcppuhelpergcc3.so.3(UDK_3_0_0) for package: openoffice.org
--> Processing Dependency: libpkgchk645li.so for package: openoffice.org
--> Processing Dependency: libvcl645li.so for package: openoffice.org
--> Processing Dependency: libstlport_gcc.so for package: openoffice.org
--> Processing Dependency: libset645li.so for package: openoffice.org
--> Processing Dependency: libvos3gcc3.so for package: openoffice.org
--> Processing Dependency: libfile645li.so for package: openoffice.org
--> Processing Dependency: libdbtools2.so for package: openoffice.org
--> Processing Dependency: libsal.so.3 for package: openoffice.org
--> Processing Dependency: libcppu.so.3(UDK_3_0_0) for package: openoffice.org
--> Processing Dependency: libsvt645li.so for package: openoffice.org
--> Processing Dependency: libsal.so.3(UDK_3_0_0) for package: openoffice.org
--> Processing Dependency: libtk645li.so for package: openoffice.org
--> Processing Dependency: libcppu.so.3 for package: openoffice.org
--> Processing Dependency: libsot645li.so for package: openoffice.org
--> Processing Dependency: libsalhelpergcc3.so.3 for package: openoffice.org
--> Processing Dependency: libcomphelp3gcc3.so for package: openoffice.org
--> Processing Dependency: libvclplug_gen645li.so for package: openoffice.org
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package openoffice.org.i386 0:1.1.2-11.5.fc3 set to be erased
---> Package openoffice.org-libs.i386 0:1.1.2-10 set to be updated      <============
--> Running transaction check
--> Processing Dependency: openoffice.org = 1.1.2-10 for package: openoffice.org-libs      <============
--> Processing Dependency: openoffice.org = 1.1.2-11.5.fc3 for package: openoffice.org-i18n
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package openoffice.org.i386 0:1.1.2-10 set to be updated      <============
---> Package openoffice.org-i18n.i386 0:1.1.2-11.5.fc3 set to be erased
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Remove: openoffice.org-libs.i386 0:1.1.2-11.5.fc3

Performing the following to resolve dependencies:
  Remove: openoffice.org.i386 0:1.1.2-11.5.fc3
  Remove: openoffice.org-i18n.i386 0:1.1.2-11.5.fc3
  Update: openoffice.org.i386 0:1.1.2-10      <============
  Update: openoffice.org-libs.i386 0:1.1.2-10      <============
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Check Error:   package openoffice.org-libs-1.1.2-11.5.fc3 (which is newer than openoffice.org-libs-1.1.2-10) is already installed
  package openoffice.org-1.1.2-11.5.fc3 (which is newer than openoffice.org-1.1.2-10) is already installed


Any thought ?

yum-2.1.12-0.fc3 
Ok, not really relevant to fedora-devel-list but Rawhide use quite the same version.

Bugzilla ?

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]