[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: DB_File needs compatible versions of libdb & db.h



Jeff Johnson wrote:
lists wrote:
DB_File needs compatible versions of libdb & db.h
you have db.h version 4.3.21 and libdb version 4.3.27
Compilation failed in require at /var/qmail/bin/qmail-scanner-queue.pl line 1246.


Upgrade to the db4-devel-4.3.27 package.

(the original message was from me)


I do have dv4-devel-4.3.27 installed

# rpm -qf /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DB_File.pm
perl-5.8.5-13

It seems DB_File.pm is from the perl package, and thats why im having problems. In lack of other options i have force installed the old db4-*4.2.21 rpms, the only dependency being pam, i hope it will keep working.

Thanks for the quick reply
Kris


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]