[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Eclipse 3.1 (was Re: rawhide report: 20050126 changes)



* Nick Bargnesi <nbargnesi gmail com> [2005-01-28 13:05]:
> java -version returns:
> 
> java version "1.4.2"
> gcj (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
[...]
> Thoughts?  This is on an x86 platform.  I tried on x86_64 last night
> with same results.

Yeah, you need to have your java alternative set to java-1.4.2-gcj4-compat.
It looks like it's currently set to java-1.4.2-gcj-compat (which uses gij
from the 3.4.x package).

Do the following (and note the 4s):

su - -c "update-alternatives --set java \
  /usr/lib/jvm/jre-1.4.2-gcj4/bin/java"
su - -c "update-alternatives --set javac \
  /usr/lib/jvm/java-1.4.2-gcj4/bin/javac"

Andrew


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]