[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ATrpms and FC5/RHEL5



On Mon, 2006-01-02 at 05:24 +0530, Rahul Sundaram wrote:
> When users choose to use third party repositories they are in many cases 
> not aware that they are not just adding packages but also replacing 
> existing ones in their system which might be a divergence they desire. 
> The discussions initiated by one such user along with various posting in 
> fedora forum, user lists and irc channel is enough proof that the 
> problem exists. Also dag, one of the third party repository packagers 
> has essentially required the exact same thing before.
> 
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=151498
> 
> Claiming that the problem is theoretical is ignoring the issue and 
> calling it politics or FUD is not going to change that.


Have we thought about maybe an 'installonly' type plugin for 3rd party
repos?  Only allow the installation of packages from that repo, exclude
it from generic 'update' calls, or only allow packages that have been
installed from said repo to be updated from said repo (and specific
deps)?  This would allow users to install specific package sets and
avoid generic update issues.  I tried to install some mono stuff from
nrpms, left nrpms configured and did a yum update and was prompted to
update a very large amount of my core over to nrpms versions of
packages.  Not cool.

-- 
Jesse Keating RHCE      (geek.j2solutions.net)
Fedora Legacy Team      (www.fedoralegacy.org)
GPG Public Key          (geek.j2solutions.net/jkeating.j2solutions.pub)

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]