[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiple installed python



On 1/3/06, Warren Togami <wtogami redhat com> wrote:
> rpm is the wrong component for this bug because it is behaving as
> designed.  Why have you not asked the general python maintainers at Red
> Hat like misa, katzj or pjones instead?  Maybe you have... but I see no
> comments from them in this ticket.

I resolved this by replacing the core package so I have python15,
python22, python23, python24; instead of having "python" as the core
package. Otherwise, an upgrade of python will implicitly Obsoletes the
other packages because they Provide a virtual python. I actually ran
through the scenarios, at length, with several individuals inside and
outside of Redhat about 1.5+ years ago. This seemed to be the best
resolution at the time since the aforementioned bug is "As Designed".

I'm mainly using this as an example about the occasional hiccups when
dealing with Core and 3rd party repos rather than rattling old bones.

--
-jeff


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]