[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Upgrading FC4 -> FC5 via yum.



Cheers for the advice all,

I can't even install the kernel though because it resolves a huge chain
of dependencies until it dies on X.

<snip>

--> Running transaction check
--> Processing Dependency: libdevmapper.so.1.02 for package: dmraid
--> Processing Conflict: hwdata conflicts system-config-display < 1.0.31
--> Processing Dependency: module-init-tools >= 3.2 for package: hwdata
--> Processing Dependency: libdevmapper.so.1.02(Base) for package:
dmraid
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package system-config-display.noarch 0:1.0.35-1 set to be updated
---> Package device-mapper.i386 0:1.02.02-3 set to be updated
---> Package module-init-tools.i386 0:3.2-0.pre9.1.1 set to be updated
--> Running transaction check
--> Processing Dependency: libdevmapper.so.1.01(Base) for package: lvm2
--> Processing Dependency: rhpl >= 0.170-1 for package:
system-config-display
--> Processing Dependency: libdevmapper.so.1.01 for package: lvm2
--> Processing Dependency: /usr/bin/Xorg for package:
system-config-display

<snip>

Error: Missing Dependency: /usr/X11R6/bin/xsetroot is needed by package
xinitrc
Error: Missing Dependency: /usr/X11R6/bin/sessreg is needed by package
xinitrc
Error: Missing Dependency: xorg-x11 is needed by package glitz
Error: Missing Dependency: xorg-x11 is needed by package xorg-x11-tools
Error: Missing Dependency: xorg-x11-libs = 6.8.2-37.FC4.49.2 is needed
by package xorg-x11-xfs
Error: Missing Dependency: xorg-x11-libs >= 6.7.99 is needed by package
libgnomeui
Error: Missing Dependency: xorg-x11-libs is needed by package pango
Error: Missing Dependency: /usr/X11R6/lib/X11/XKeysymDB is needed by
package openmotif
Error: Missing Dependency: libdps.so.1 is needed by package ImageMagick
Error: Missing Dependency: libdpstk.so.1 is needed by package
ImageMagick
Error: Missing Dependency: fonts-xorg-75dpi is needed by package emacs

Doh.. "Conflict: hwdata conflicts system-config-display" seems to be my
problem as that is where it decides to pull in everything X related.


On Mon, 2006-01-16 at 19:23 +0530, Rahul Sundaram wrote:
> Hi
> 
> >You are way in the Testing guide is just fine, i just described a way
> >using yumex, because it is easier to find the stuff to be remove on a
> >FC4 system with a lot of 3 party stuff, there are making dependency
> >troubles when updating to Rawhide and i want use the the best mirror
> >detection included in the lastest yumex release to speedup the package
> >download by using the most updated and fastest mirrors.
> >
> >
> >Tim
> >  
> >
> Well you can get these documented within the testing guide and add a one 
> stop reference. If you need edit access to the wiki, let me know.
> 
> 
> -- 
> Rahul 
> 
> Fedora Bug Triaging - http://fedoraproject.org/wiki/BugZappers



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]