[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: removing kernel-devel rpms



Bart Vanbrabant wrote:
> Hello,
>
> A few weeks back I installed xen and the kernels needed to run it. These
> kernels where to old to run the new udev and stuff like that so I
> removed them. I managed to remove them all except
> kernel-xen-hypervisor-devel. Now when I try to remove this package or
> any other kernel-devel package rpm starts to use 100% cpu and eating up
> all my memory (no swapping) and that's it. I have to kill it with kill -9.
> I also tried removing it with yum but this gives the same result.
> When I run rpm with -vvv I get this output:
>
> D: opening  db environment /var/lib/rpm/Packages joinenv
> D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
> D: locked   db index       /var/lib/rpm/Packages
> D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
> D:  read h#     495 Header SHA1 digest: OK
> (ac5184f6a47674edad14c13ec3ada90fbccdbe0f)
> D: ========== --- kernel-devel-2.6.14-1.1805_FC5 i686/linux 0x0
> D: opening  db index       /var/lib/rpm/Requirename rdonly mode=0x0
> D: ========== recording tsort relations
> D: ========== tsorting packages (order, #predecessors, #succesors, tree,
> depth, breadth)
> D:     0    0    0    0    1    0   -kernel-devel-2.6.14-1.1805_FC5.i686
> D: closed   db index       /var/lib/rpm/Requirename
> D: closed   db index       /var/lib/rpm/Name
> D: closed   db index       /var/lib/rpm/Packages
> D: closed   db environment /var/lib/rpm/Packages
> D: opening  db environment /var/lib/rpm/Packages joinenv
> D: opening  db index       /var/lib/rpm/Packages create mode=0x42
> D: mounted filesystems:
> D:     i        dev    bsize       bavail       iavail mount point
> D:     0 0x00001602     4096      2011197      2541260 /
> D:     1 0x00000003     4096            0           -1 /proc
> D:     2 0x00000000     4096            0           -1 /sys
> D:     3 0x0000000a     4096            0           -1 /dev/pts
> D:     4 0x00000012     4096       129398       129397 /dev/shm
> D:     5 0x00001605     4096      1693426     27282253 /home
> D:     6 0x00000013     4096            0           -1
> /proc/sys/fs/binfmt_misc
> D:     7 0x00000014     4096            0           -1
> /var/lib/nfs/rpc_pipefs
> D:     8 0x00001601     8192       648695           -1 /media/WINDOWS
> D: sanity checking 1 elements
> D: running pre-transaction scripts
> D: computing 7898 file fingerprints
> D: computing file dispositions
> D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
>
> Here it stops doing stuff. When I try to remove a package for the first
> time I see a lot of hd activity first before I goes to 100% cpu usage.
> The second time I try it does it directly.
>
> I tried rebuilding my rpm database. Also by first removing the __db*
> files in /var/lib/rpm/ but that doesn't work either.
>
> Is there a way to remove this packages? Because I start to get quite
> some kernel-devel packages and it's probably a bug.
>
> thanks,
>
> Bart
>
>   
Anyone? Should I file this as a bug report?

Bart

-- 
Bart Vanbrabant <bart vanbrabant zoeloelip be>
PGP fingerprint: 093C BB84 17F6 3AA6 6D5E  FC4F 84E1 FED1 E426 64D1


Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]