[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20070803 changes



Erik van Pienbroek wrote, at 08/04/2007 05:22 AM +9:00:
> Op vrijdag 03-08-2007 om 09:12 uur [tijdzone -0400], schreef Build
> System:
> New package rarian
>> 	Rarian is a documentation meta-data library
>>
>>
> This package causes yum to refuse to update:

Still no good:
[root localhost ~]# yum upgrade yelp
<snip>
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 yelp                    i386       2.19.1-3.fc8     koji              681 k
Installing for dependencies:
 rarian                  i386       0.5.6-4.fc8      koji               98 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 779 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
--> Populating transaction set with selected packages. Please wait.
---> Package rarian.i386 0:0.5.6-4.fc8 set to be updated
---> Package yelp.i386 0:2.19.1-3.fc8 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package gconf-editor needs scrollkeeper, this is not available.
Package gconf-editor needs scrollkeeper, this is not available.
Package gucharmap needs scrollkeeper, this is not available.
Package gucharmap needs scrollkeeper, this is not available.
<followed by so many errors>

Strangely:

[root localhost ~]# yum install rarian-compat
<snip>
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 rarian-compat           i386       0.5.6-4.fc8      koji               96 k
Installing for dependencies:
 rarian                  i386       0.5.6-4.fc8      koji               98 k

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         
<snip>
Transaction Test Succeeded
Running Transaction
  Installing: rarian                       ######################### [1/3] 
  Installing: rarian-compat                ######################### [2/3] 
  Removing  : scrollkeeper                 ######################### [3/3]

Installed: rarian-compat.i386 0:0.5.6-4.fc8
Dependency Installed: rarian.i386 0:0.5.6-4.fc8
Complete!
[root localhost ~]# yum upgrade yelp
<snip>
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 yelp                    i386       2.19.1-3.fc8     koji              681 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         
<snip>
Transaction Test Succeeded
Running Transaction
  Updating  : yelp                         ######################### [1/2] 
  Cleanup   : yelp                         ######################### [2/2]

Updated: yelp.i386 0:2.19.1-3.fc8
Complete!

I think this is showing that yum-3.2.2-3.fc8 is broken in unknown way. 

I also think that this is related to that some people complain that 
perl-devel cannot be upgraded due to missing perl(ExtUtils::Embed) dependency:
https://www.redhat.com/archives/fedora-devel-list/2007-August/msg00267.html

Mamoru


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]