[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide perl update problem



Steve G <linux_4ever yahoo com> writes:

> Hi,
>
> For about a week, yum update perl has done this:
>
> Running rpm_check_debug
> --> Populating transaction set with selected packages. Please wait.
> ---> Package perl-Test-Simple.x86_64 0:0.62-22.fc8 set to be updated
> ---> Package perl-libs.x86_64 4:5.8.8-22.fc8 set to be updated
> ---> Package perl-CPAN.x86_64 0:1.76_02-22.fc8 set to be updated
> ---> Package perl-devel.x86_64 4:5.8.8-22.fc8 set to be updated
> ---> Package perl-Test-Harness.x86_64 0:2.56-22.fc8 set to be updated
> ---> Package perl.x86_64 4:5.8.8-22.fc8 set to be updated
> ---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.30-22.fc8 set to be updated
> ERROR with rpm_check_debug vs depsolve:
> Package perl-devel needs perl(ExtUtils::Embed), this is not available.
> Complete!
>
> Doing "yum install perl-ExtUtils-Embed" causes the dependency to be correctly
> resolved and perl updated.

I can't seem to reproduce this - perl-ExtUtils-Embed provides
perl(ExtUtils::Embed) and perl-devel requires the same.  Is the x86_64
arch confusing yum somehow?

-RN

-- 
Robin Norwood
Red Hat, Inc.

"The Sage does nothing, yet nothing remains undone."
-Lao Tzu, Te Tao Ching


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]