[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: strange failure for dependency against libdb-4.5.so



On Fri, 17 Aug 2007 18:30:26 +0200, Michael Schwendt wrote:

> On Sat, 18 Aug 2007 00:51:09 +0900, Mamoru Tasaka wrote:
> 
> > Mamoru Tasaka wrote, at 08/18/2007 12:45 AM +9:00:
> > > Jindrich Novy wrote, at 08/17/2007 09:08 PM +9:00:
> > >> On Fri, Aug 17, 2007 at 11:57:51AM +0300, Ville Skyttä wrote:
> > >>> On Friday 17 August 2007, Jindrich Novy wrote:
> > >>>> db4 was updated recently to 4.6.18, and older db-4.5.20 was moved to
> > >>>> compat-db
> > >>> compat-db seems to have some self-obsoletion issues, that may have 
> > >>> something to do with the problems:
> > >>>
> > >>> Obsoletes: db4 < 4.6, db4-devel < 4.6, db4-utils < 4.6, db4-tcl < 
> > >>> 4.6, db4-java < 4.6
> > >>> Provides: db4 = 4.2.52, db4 = 4.3.29, db4 = 4.5.20
> > >>> Provides: db4-devel = 4.2.52, db4-devel = 4.3.29, db4-devel = 4.5.20
> > >>>
> > >>> The Obsoletes should probably be < 4.2.52 instead of < 4.6.
> > >>
> > >> The original intention was a possibility to replace an existing old db4
> > >> with compat-db without conflicts. I decreased the obsoletes and build
> > >> new compat-db so it sould be ok now.
> > > 
> > > Umm.. still no good. Currently I cannot figure out how to resolve
> > > this issue.
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=107120
> > > 
> > > (according to i386 half‐finished (cancelled) root.log, buildroot seems to
> > > install new compat-db 4.5.20-2.fc8:
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=107111 )
> > The latter one is not 107111, but:
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=107121
> 
> A "cvs diff -u -r 1.22 1.24 compat-db.spec" shows that the Provides/Obsoletes
> were added in compat-db-4_5_20-1_fc8 and after compat-db-4_3_29-2_fc7
> 
> If RPM in the build environment is a version that obsoletes packages
> based on virtual provides, these Provides/Obsoletes in compat-db are
> the culprit. In short, when compat-db "Provides: db4 = some-low-version",
> the "db4" packages with a higher version upgrades compat-db. Some
> background can be found here: https://bugzilla.redhat.com/111071
> It has effected multiple packages since FC =~ 1

Typos! Three last lines above should read:

  the "db4" package with a higher version upgrades compat-db. Some
  background can be found here: https://bugzilla.redhat.com/111071
  It has affected multiple packages since FC =~ 1
 
> Recently, Panu has mentioned that this "feature" in RPM will go away
> in a future release of RPM. But until then, don't use such virtual
> provides. They break.
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]