[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: strange failure for dependency against libdb-4.5.so



On Sat, Aug 18, 2007 at 10:47:51AM +0200, Michael Schwendt wrote:
> On Sat, 18 Aug 2007 10:38:47 +0200, Jindrich Novy wrote:
> 
> > Ok, the new compat-db without db4-* provides is now built. I'm Cc'ing
> > fedora-maintainers as well so that everyone is aware that direct
> > library dependencies are now needed for packages using older db4s.
> 
> What kind of "direct library dependencies"? Any of the binary rpms
> depend on the SONAME and don't need a change when a library is moved
> from one package to another. That's one of the primary reasons why we
> rely on rpmbuild's automatic dependencies instead of adding explicit
> dependencies on package %{name}s manually. Only packages, which want
> to build against compat-db-devel, would need to adjust the
> BuildRequires.
> 

compat-db-devel doesn't exist. I was trying to say, that Requires: db4 = 4.3.29
and similar won't work any more in rawhide so it has to be changed to something like
Requires: compat-db >= 4.3.29 (recommended). Or something uglier like
to require the library directly: Requires: libdb-4.3.so and libdb-4.3.so()(64bit)
in case of 64bit arches, what is really ugly.

Jindrich

-- 
Jindrich Novy <jnovy redhat com>   http://people.redhat.com/jnovy/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]