[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Ugly dependency checker



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This [1] is a rather ugly dependency checker for any number of
repositories. It uses yum to search for requirements that cannot be
resolved.

I thought maybe because there's no dependency checking yet on updates
and such (don't know the details), and I needed this anyway, I'd just
dump it here and collect some useful comments.

When executing the script you'll have a few options:

- --config
	pass it a yum config with repos listed in it (in fact it's just
	walking over all sections, check if they're enabled and take the
	name, baseurl and mirrorlist) It doesn't do el-reposdir
	thingies.

- --repo
	Just check this or that repo (provide full "baseurl")

- --recent
	Just check the most recent set of packages and ignore any older
	versions of foo, bar and baz

- --efficient
	This is the really weird one because I could just iterate over
	all packages and try to resolve their requirements one by one,
	but in this mode the script just builds a list of requirements,
	yum.misc.unique()'s them, and searches the providers for each of
	these. Saves like a ton of time.

- --arch
	Obvious. Maybe useless. Defaults to i386.

- --debuglevel
	Description says: "Whatever debuglevel yum takes" < and that's
	true, because the only thing the script does with it is writing
	it to the temp yum config.

Again, one morning rather well-spent.

[1]
http://git.fedoraproject.org/?p=hosted/revisor;a=blob_plain;f=scripts/depchecker.py
- --
Kind regards,

Jeroen van Meeuwen
- -kanarip

- --
http://www.kanarip.com/
RHCE, LPIC-2, MCP, CCNA
C6B0 7FB4 43E6 CDDA D258  F70B 28DE 9FDA 9342 BF08
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGytaqKN6f2pNCvwgRAu11AKCVwWj8hm8ZfGDytw3kqKJJKcj7WACgj0ff
UYWlHW6eLNAYUyfYeeYaeSI=
=Ks3D
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]