[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

obsoleting in compat packages: is it right?



Hello,

Sometime there are obsolete of older packages by compat packages. The
idea is that when coming from an old package a compatible package is
needed. This is what is done in automake16. It is a compat package, and
it has

Obsoletes:  automake = 1.6.3

It makes sense, however I am not sure that it is that right, since 
somebody having automake-1.6.3-* would also want to  have the latest
automake version.

Another issue is that for this scheme to be really effective, one should
have in automake15
Obsoletes:  automake < 1.6.0 and automake >= 1.5.0

and in automake16
Obsoletes:  automake < 1.7.0 and automake >= 1.6.0

which, unless I am wrong, cannot be done in rpm.

So, what do you think? Is that practice wrong, right, or should it be 
left to the maintainer? 

I would personally think that it is wrong, it could be right if one could 
express that when updating 1.6.x, this package should be installed in 
addition to the latest package with same name.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]