[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 updates broken deps?



Florin Andrei wrote:
Thomas M Steenholdt wrote:

Really - The reason dependency issues are such a big issue for fedora is that all updates are held back because of a single package missing a dependency. I'm sure everybody would feel better holding back one package instead of all updates on this account.

If I'm not mistaken, yum seems fairly unique in this regard.

I mean, heck, look at Microsoft for example. Their update thing applies as many patches as possible, and those that cannot be applied, well duh, they don't get applied and the user is notified by big honking red icons that something failed.

But a single error doesn't nuke the whole process. yum is _really_ boneheaded from this perspective. Your argument that a possibly much more important security update might get masked by a dependency error and is not applied is a very serious one and I don't think there can be any logical rebuttal.

yum needs to be fixed, NOW. At this moment the update process puts everyone at risk.

correct.
I think we should agree that yum _is_ broken here and needs to be fixed.
and no including a optional plugin won't help, the default behavior is broken ( I would even say its a security bug)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]