[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 updates broken deps?



seth vidal wrote:
On Mon, 2007-02-26 at 15:59 +0100, Denis Leroy wrote:

Maybe I'm mistaken. If I submit a patch that integrates --skip-broken into yum, will you accept it ? I'd be more than happy to write that patch.

It really depends on how the patch is implemented. Though I'm curious
why integrating it is important if the plugin works well enough?

let me try to answer that.

1. because the plugin is not installed by default, much less enabled by default. As a new user, I would be confused by a large update failing because of a single broken dep. My instinctive reaction would be to look for an option in yum to change that behavior (assuming i even know about yum, rather than just using the update applet). Having to launch pirut and search for a plugin seems counter-intuitive to me.

2. I find that strictly relying on plugins to work around issues, change default behaviors and add new functionality, or more generally accepting contributions from the community, is a strange way of managing a project. At least that's the way I understand yum is managed right now, based on what Tom Callaway said sunday at FOSDEM. But if you tell me that's not the case, I'll certainly believe you.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]