[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 updates broken deps?



On Mon, 2007-02-26 at 16:29 +0100, Denis Leroy wrote:

> let me try to answer that.
> 
> 1. because the plugin is not installed by default, much less enabled by 
> default. As a new user, I would be confused by a large update failing 
> because of a single broken dep. My instinctive reaction would be to look 
> for an option in yum to change that behavior (assuming i even know about 
> yum, rather than just using the update applet). Having to launch pirut 
> and search for a plugin seems counter-intuitive to me.



> 2. I find that strictly relying on plugins to work around issues, change 
> default behaviors and add new functionality, or more generally accepting 
> contributions from the community, is a strange way of managing a 
> project. At least that's the way I understand yum is managed right now, 
> based on what Tom Callaway said sunday at FOSDEM. But if you tell me 
> that's not the case, I'll certainly believe you.

I don't know what Spot said at fosdem so I can't really comment on that.

Mostly we've been focusing on optimization, fixing bugs and changing a
fair bit of behavior. The plugins are there so we don't have to get
bogged down in feature requests and can let users do a lot of it on
their own.

The other reason the plugins exist is b/c once something makes it into
the base yum code it has to stay there for a while. It has to be
supported and has to be lugged along.

-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]