[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 updates broken deps?



seth vidal wrote:
On Mon, 2007-02-26 at 11:11 -0800, Florin Andrei wrote:
dragoran wrote:

because this way its nothing but a hack that does not solve the main problem: yum should _NOT_ fail to update a package because a unreleated package has a dep problem.
Let me re-phrase it:

The light in the kitchen should not fail to function because a bulb in the basement is broken.

to extend the analogy:
if the bulb in the basement being out means there could well be a
murderer down there, then maybe the door to the house shouldn't open at
all. :)


I still don't get this.. do you really think that having no updates is better than having all non broken updates? sorry but this does not make any sense to me...
lets say there is a security hole in httpd -> update released
there is a bugfix (non security update) for a game but with a broken dep (can happen...) -> this blocks the whole update process... so its better in your opinion to let the system vunerable to attacks only because a unrelated package has a broken dep? even if package 2 was a security update too there is no reason to block 1 because this one has broken deps .. sure there is a problem when suchs things happen but why let our users systems with unpatched security holes even when the fix is released?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]