[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Dependency Hell[F7-x86_64]



I was going to rip NetworkManager out of my machine just now, and yum
went in and found some really nifty dependencies that made me sit up and
take notice.  I can't believe that pidgin and evolution really use NM
libs.  Is this for real?

[sean home-desk ~]$ sudo yum -y remove 'NetworkManager*'
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager-glib.x86_64 1:0.6.5-7.fc7 set to be erased
---> Package NetworkManager.i386 1:0.6.5-7.fc7 set to be erased
---> Package NetworkManager-gnome.x86_64 1:0.6.5-7.fc7 set to be erased
---> Package NetworkManager-openvpn.x86_64 0:0.3.2-7.fc6 set to be
erased
---> Package NetworkManager.x86_64 1:0.6.5-7.fc7 set to be erased
---> Package NetworkManager-glib.i386 1:0.6.5-7.fc7 set to be erased
--> Processing Dependency: libnm_glib.so.0 for package: evolution
--> Processing Dependency: libnm_glib.so.0()(64bit) for package:
libpurple
--> Processing Dependency: libnm_glib.so.0()(64bit) for package: pidgin
--> Processing Dependency: libnm_glib.so.0()(64bit) for package:
evolution
--> Processing Dependency: libnm_glib.so.0()(64bit) for package:
krb5-auth-dialog
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package NetworkManager-glib.x86_64 1:0.6.5-7.fc7 set to be erased
---> Package evolution.x86_64 0:2.10.2-3.fc7 set to be erased
---> Package evolution.i386 0:2.10.2-3.fc7 set to be erased
---> Package pidgin.x86_64 0:2.0.2-3.fc7 set to be erased
---> Package NetworkManager-glib.i386 1:0.6.5-7.fc7 set to be erased
---> Package krb5-auth-dialog.x86_64 0:0.7-2 set to be erased
---> Package libpurple.x86_64 0:2.0.2-3.fc7 set to be erased
--> Processing Dependency: libpurple.so.0()(64bit) for package:
nautilus-sendto
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package nautilus-sendto.x86_64 0:0.10-4.fc7 set to be erased
---> Package libpurple.x86_64 0:2.0.2-3.fc7 set to be erased

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository
Size 
=============================================================================
Removing:
 NetworkManager          i386       1:0.6.5-7.fc7    installed
1.8 M
 NetworkManager          x86_64     1:0.6.5-7.fc7    installed
1.8 M
 NetworkManager-glib     x86_64     1:0.6.5-7.fc7    installed
24 k
 NetworkManager-glib     i386       1:0.6.5-7.fc7    installed
18 k
 NetworkManager-gnome    x86_64     1:0.6.5-7.fc7    installed
430 k
 NetworkManager-openvpn  x86_64     0.3.2-7.fc6      installed
208 k
Removing for dependencies:
 evolution               x86_64     2.10.2-3.fc7     installed
59 M
 evolution               i386       2.10.2-3.fc7     installed
59 M
 krb5-auth-dialog        x86_64     0.7-2            installed
56 k
 libpurple               x86_64     2.0.2-3.fc7      installed
17 M
 nautilus-sendto         x86_64     0.10-4.fc7       installed
237 k
 pidgin                  x86_64     2.0.2-3.fc7      installed
16 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove      12 Package(s)         



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]