[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No shape and sync extensions in xorg?



On Sun, 2007-03-18 at 18:43 +0100, Dennis Jacobfeuerborn wrote:
> Hi,
> When I try to enable the desktop effects (ie. compiz) I get the following 
> output:
> 
> [dennis nexus ~]$ desktop-effects
> compiz: No sync extension
> The program 'gnome-window-decorator' received an X Window System error.
> This probably reflects a bug in the program.
> The error was 'BadMatch (invalid parameter attributes)'.
>    (Details: serial 426 error_code 8 request_code 72 minor_code 0)
>    (Note to programmers: normally, X errors are reported asynchronously;
>     that is, you will receive the error a while after causing it.
>     To debug your program, run it with the --sync command line
>     option to change this behavior. You can then get a meaningful
>     backtrace from your debugger if you break on the gdk_x_error() function.)
> Xlib:  extension "SHAPE" missing on display ":0.0".

Your X config file has a Modules section, and it doesn't contain a line
for extmod.

You claim to be using the nv driver later in the thread, but compiz
isn't going to work with that setup, period, because we don't have a DRI
driver for nvidia cards yet.  More likely you installed nvidia's closed
driver, and the install script for same added a Modules section that it
didn't need to.

- ajax


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]