[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Memory usage - default X install can't use yum with 1GB RAM machine



On Thursday 11 October 2007, Paul Wouters wrote:
> On Thu, 11 Oct 2007, Peter Arremann wrote:
> > On Thursday 11 October 2007, Paul Wouters wrote:
> > >   PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
> > >  3983 paul      20   0 1002m 284m  19m R  9.9 28.7  32:17.87
> > > firefox-bin 2582 root      20   0  568m 106m 4680 S  0.7 10.8 198:43.15
> > > X
> >
> > You happen to run xinerama?
>
> Nope. Stock install , one screen, using the "nv" driver.
>
> Paul

Hm - I used the nv driver but got the same behavior only when using dual head. 
For me it turned out to be that firefox seems to hold onto bitmaps way too 
much. Especially when you browse webpages with lots of images, that quickly 
gets to be a pain. xrestop showed that most of the memory used by X came from 
firefox - Pxm mem column... There are some xorg bug reports out there for 
that behavior, but most of them revolve around xinerama too. 

https://bugs.freedesktop.org/show_bug.cgi?id=4942

and many others - they are old and still in new status... On the mozilla pages 
you will see similar reports... 

One solution that seems to work for many is switching to the nvidia closed 
source drivers. If you want to stay open source, try nouveau.
http://nouveau.freedesktop.org/wiki/

Both of them can fix the high pixmap memory usage for some people. Others have 
no luck with either.

Peter.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]