[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Provides/Obsoletes question



On Tue, Oct 16, 2007 at 11:42:51AM -0400, Steve Dickson wrote:
> I'm trying to rename the libgssapi-0.11-2.fc8 package
> into libgssglue-0.1-2.fc8 and I'm getting file conflictions
> on a common config file.
> 
> Now reading the http://fedoraproject.org/wiki/Packaging/NamingGuidelines
> its seems all I have to do is added a Provides and Obsoletes cause to
> the new spec file and the file conflictions will be resolved.
> Unfortunately I must be not understanding something since no matter
> what I do, I can not get ride of the file confliction.
> 
> So I'm hoping a "second pair of eyes" will be able to show
> what I'm doing wrong.
> 
> The old package is libgssapi-0.11-2.fc8
> The new package is libgssglue-0.1-2.fc8
> The libgssglue.spec file entry is:
> 
> Provides: libgssapi = %{version}-%{release}
> Obsoletes: libgssapi <= 0.11-2
> 
> The error is:
> # rpm -ihv libgssglue-0.1-2.fc8
> Preparing...                ########################################### 
> [100%]
>         file /etc/gssapi_mech.conf from install of libgssglue-0.1-2.fc8 
> conflicts with file from package libgssapi-0.11-2.fc8
> #
> 
> Anybody have a clue as to what I'm doing wrong?

Shouldn't you be trying todo an upgrade, rather than install ? eg  -Uhv 
An install will simply try to install it in parallel with existing RPM
which will clash on files, while an upgrade should do the replacement
correctly.

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]