[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm and post script install/run order question (texlive) [2]



On Tue, Oct 09, 2007 at 05:59:28PM +0200, Phil Knirsch wrote:
>
> Well, from looking at the dependencies you listed here the dependency tree 
> would look like this:
>
>
>
>
> updmap-sys    texconfig-sys    C
>   /|\             /|\
>    |               |
>            E       B
>           /|\
>            |
>            D
>           /|\
>            |
>            A

I don't really understand the diagram...

But I'd like to precise that updmap-sys and texconfig-sys are part of
the package A.

> So effectively this means that on the 1st level of the tree updmap-sys, 
> texconfig-sys and C can be ordered in any way as well as on the 2nd level E 
> and B as they have no cross and/or chained dependencies.

That's annoying...

> So to answer your questions:
>
> 1) Can C be installed prior to sA being called: No, as the dependency chain 
> clearly require B, C and D and therefore those will be installed prior to 
> A.

Maybe I wasn't clear, but sA is in A...

> 2) Will the various yum install [A|E|B] give the same script run orders? 
> Thats not 100% guaranteed as the installation order of E and B as well as 
> the installation of updmap-sys, texconfig-sys and C are not fixed by any 
> requires, so using a subset of packages to install first (e.g. only 
> updmap-sys, texconfig-sys and C) might result in a different order for 
> those packages than using a "full" install with A.

Once again, updmap-sys and texconfig-sys are in A...

> There might be some code inside rpm that could possibly have updmap-sys, 
> texconfig-sys and C be installed in the same order despite having not 
> dependencies between each other, but from an algorithmical point of view 
> you can't and shouldn't rely on it.

It is clearly something that shouldn't be done.

> Or to put it differently: If you need those packages to be installed in a 
> specific order then just use Requires.

The issue is that the postscript should only be run after all are
installed.

> On the other hand, if those are "soft" requires then things get tricky , 
> e.g. IF updmap-sys, texconfig-sys and C get installed then C needs to be 
> installed after updmap-sys and/or texconfig-sys. I remember vaguely that 
> such "soft" requires (which don't pull in packages automatically but which 
> will be honored in case it is already in the transaction) were either 
> planed or even already put into rpm, but Panu/JBJ can probably tell you a 
> lot more in detail about that.

Maybe this could be useful.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]