[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiarch crazyiness



Le lundi 22 octobre 2007 à 14:56 -0400, Bill Nottingham a écrit :

> One *big* issue with doing this change across the board is that you'll go
> from the repository having:
> 
> - foo.i386 and foo.x86_64
> 
> to:
> 
> - foo.x86_64 and foo-libs.i386 and foo-libs.x86_64
> 
> So, on upgrade, yum will grab foo.x86_64 to upgrade the older install. It
> will then pull in foo-libs.x86_64 for dependencies. Meanwhile, the old
> foo.i386 will remain, often leading to conflicts.

Wouldn't an Obsoletes: foo < current_version fix this? Unless we want to
ship 32bit & 64bit versions of foo in the same repo

-- 
Nicolas Mailhot

Attachment: signature.asc
Description: Ceci est une partie de message numériquement signée


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]