[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Frequent crashes of PulseAudio



Dnia 2008-04-07, pon o godzinie 16:52 -0400, Dimi Paun pisze:
> On Mon, 2008-04-07 at 22:39 +0200, Lennart Poettering wrote:
> > 
> > If you get a CPU time limit abort than this can have two reasons:
> > 
> > 1) You got an awfully slow CPU (very unlikely, if you bought your
> > machine in the last 10 years and is x86 or x86-64)
> > 
> > 2) Something causes PA to enter an endless loop which causes it to eat
> > 100% CPU.
> > 
> > In all the cases I managed to track down #2 is caused by a faulty ALSA
> > driver where poll() signalled readiness while there actually was
> > nothing to do. This happened with drivers which required the "multi"
> > libasound module, such as emu10k.
> 
> Well, 1) clearly doesn't apply to me, I'm running on Core Duo 6400.

Duron 1,6GHz here.

> As for 2) it is true that I have noticed PA start using 100% CPU for
> a few seconds before exiting. Randomly. A lot of times I find it gone
> in the morning, with no music playing during the night.

Didn't noticed...

> As for sound card, I'm using a bog-standard Intel Corporation 82801H
> (ICH8 Family) HD Audio Controller (rev 02).

snd-via82xx: VIA 8235 integrated soundcard. AC97 standard.

-- 
Jakub 'Livio' Rusinek
http://liviopl.jogger.pl/

Attachment: signature.asc
Description: To jest część wiadomości podpisana cyfrowo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]