[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Automatic python requires



On Wed, Apr 30, 2008 at 09:47:36AM +0200, Christian Iseli wrote:
> On Wed, 30 Apr 2008 09:26:33 +0200, Patrice Dumas wrote:
> > It is not a problem, just unneeded. It adds difference with upstream,
> > may require patching and so on,
> 
> Usually, a 'sed -i' line in %setup is enough, so I wouldn't call it a
> big burden.

Indeed, but guidelines are already big, so if it possible not to add
mandadorily guidelines, it is better.

> > better leave it to te packager.
> 
> Sure.  But I think a "recommendation" line somewhere might actually be
> good, with some rationale that it:
> - allows rpm to get the dependencies right
> - avoids user confusion when the wrong interpreter is called
> - maybe something else I forget...

I fully agree, but it shouldn't be a guideline, only a recommendation
(in a place where we put recommentdations).

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]