[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

cdparanoia III 10 license change



cdparanoia 10 is GPLv3 and LGPLv3.  This is a change from 9.8.

Affected components:

atropine:~% rpm -q --provides cdparanoia-libs | while read i junk ; do
repoquery --qf="%{name}\n" --whatrequires $i ; done | sort -u
bmpx
cdparanoia
cdparanoia-debuginfo
cdparanoia-devel
cdparanoia-libs
grip
gstreamer-plugins-base
kaffeine
kdemultimedia-libs

Of these, bmpx and kdemultimedia-libs claim to be v2-only.  My reading
of the compatibility matrix is that you can't link to a LGPLv3 library
from GPLv2 code.  gstreamer-plugins-base only claims to be LGPL in the
License tag.  It appears to be LGPLv2.1 accordig to the license text,
and my reading of the compat matrix is that linking to LGPLv3 from
LGPLv2 is okay.  The cdparanoia source plugin is explicitly LGPLv2+.

<ajax> whoowns bmpx
<zodbot> bmpx is owned by akahl
<ajax> whoowns kdemultimedia
<zodbot> kdemultimedia is owned by than
<ajax> fas akahl
<zodbot> akahl 'Alexander Kahl' <akahl iconmobile com>
<ajax> fas than redhat com
<zodbot> than 'Than Ngo' <than redhat com>

If this is you, either your License tag is broken, or your package is
about to be.

- ajax

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]