[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: koji build problem



On Thu, 05 Jun 2008 22:58:05 +0100
Paul <paul all-the-johnsons co uk> wrote:

> Hi,
> 
> I'm trying to get monodevelop-1.0 to build for F9, but it looks like
> something is snarled up somewhere with koji
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=648795
> 
> Koji is complaining that gtksourceview2-sharp-devel and
> mono-basic-devel don't exist despite them plainly being there.

Hmm, very odd, don't know what's going on there.

> The build log is showing something really odd
> 
> ENTER do(['bash', '--login', '-c', 'rpmbuild -bs --target x86_64
> --nodeps builddir/build/SPECS/monodevelop.spec'], False,
> '/var/lib/mock/dist-f9-build-201996-35034/root/', None, 0, True, 0,
> 423, 104, None, logger=<mock.trace_decorator.getLog object at
> 0x2aaab0e8bf90>)
> Executing command: ['bash', '--login', '-c', 'rpmbuild -bs --target
> x86_64 --nodeps builddir/build/SPECS/monodevelop.spec'] /etc/profile:
> line 38: /bin/hostname: No such file or directory sh: gacutil:
> command not found sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> sh: gacutil: command not found
> warning: Could not canonicalize hostname: hammer2.fedora.redhat.com
> Building target platforms: x86_64
> Building for target x86_64
> Wrote: /builddir/build/SRPMS/monodevelop-1.0-6.fc9.src.rpm
> 
> Any ideas on what is going wrong here? I've tried both a normal and
> scratch build with the same level of success.

That all looks like the normal output for a successful build of the
SRPM in a mock chroot with gacutil and hostname not present. The SRPM
build worked OK. The problem isn't here, it's the apparently missing
buildreqs mentioned earlier.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]