[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PackageKit UI



2008/6/13 Richard Hughes <hughsient gmail com>:
> On Thu, 2008-06-12 at 16:02 +0100, Naheem Zaffar wrote:
>> Been using packagekit for Fedora 9, and I generally like what I see
>> (good work!) things that I think can be improved/current problems:
>>
>> 1. Do NOT list multiple versions of the same package. I see that in
>> current Fedora release too. At times the version numbers are not that
>> easy to compare package-x.y.1.y vs package-x.y.y.1 makes a person
>> think. Other times if both are uninstalled, selecting the wrong one
>> will probably lead to an updated available applet anywway...
>
> Sure. We've got a LATEST filter in PackageKit for this, but the yum
> backend doesn't seem to support it. I might hack on that today on the
> plane.
>
>> Solution: only list one - the latest one. If an update is available to
>> the installed version, use the corresponding update icon
>> (bugfix/enhancement/security) instead of an open or closed box.
>
> Sane.

Disagree. If you installed something from updates-testing and want to
downgrade to original release or stable update, that should be listed
too (with an option to downgrade, preferably presented exactly the way
as for a newer one, but perhaps dimmed or something).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]