[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gnutls upgrade in rawhide to 2.4.0 and license change



I plan to do gnutls library update in rawhide to version 2.4.0 soon.
Unfortunately the ABI of this version is different from 2.0.4 as is
currently in rawhide. That means that all the libraries and applications
which depend on it will have to be rebuilt.

The new version also changes license on the libgnutls-extra and
libgnutls-openssl libraries and on the utilities which are part of this
package from GPLv2+ to GPLv3+. The main libgnutls library is unaffected
by this licence change as it stays at LGPLv2.1+. It seems that the only
packages currently in rawhide which depend on these two extra libraries
are mcabber and gkrellm which have compatible license with GPLv3 so
there should be no problem with that.

The packages which will have to be rebuilt due to the ABI change are
here:

aiccu-2007.01.15-3.fc9.src.rpm
aria2-0.12.0-4.fc9.src.rpm
bitlbee-1.2-1.fc9.src.rpm
buoh-0.8.2-4.fc9.src.rpm
climm-0.6.2-1.fc9.src.rpm
ctrlproxy-3.0.5-2.fc9.src.rpm
cups-1.3.7-9.fc10.src.rpm
drivel-2.1.1-0.5.20071130svn.fc9.src.rpm
ekg2-0.2-0.1.rc1.fc10.src.rpm
filezilla-3.0.11-1.fc10.src.rpm
gkrellm-2.3.1-3.fc9.src.rpm
gnutls-2.0.4-3.fc10.src.rpm
gobby-0.4.5-3.fc9.src.rpm
gtk-gnutella-0.96.5-1.fc9.src.rpm
gtk-vnc-0.3.6-1.fc10.src.rpm
gurlchecker-0.10.1-8.fc9.src.rpm
hardinfo-0.4.2.3-5.fc9.src.rpm
heartbeat-2.1.3-1.fc9.src.rpm
iksemel-1.3-4.fc9.src.rpm
jd-2.0.0-0.6.svn2129_trunk.fc10.src.rpm
kazehakase-0.5.4-4.fc9.src.rpm
kvm-70-1.fc10.src.rpm
libepc-0.3.5-1.fc10.src.rpm
libggz-0.0.14.1-1.fc9.src.rpm
libprelude-0.9.17.1-1.fc10.src.rpm
libpreludedb-0.9.14.1-2.fc9.src.rpm
libsoup22-2.2.105-2.fc9.src.rpm
libsoup-2.23.1-3.fc10.src.rpm
libtranslate-0.99-14.fc9.src.rpm
libvirt-0.4.3-1.fc10.src.rpm
liferea-1.4.15-5.fc9.src.rpm
loudmouth-1.4.0-1.fc10.src.rpm
mcabber-0.9.6-1.fc9.src.rpm
msmtp-1.4.13-4.fc9.src.rpm
mutt-1.5.18-2.fc10.src.rpm
neon-0.28.2-3.src.rpm
net6-1.3.5-3.fc9.src.rpm
ntfsprogs-2.0.0-7.fc10.src.rpm
obby-0.4.4-3.fc9.src.rpm
prelude-lml-0.9.12.2-1.fc10.src.rpm
prelude-manager-0.9.12.1-1.fc10.src.rpm
qemu-0.9.1-9.fc10.src.rpm
rsyslog-3.19.7-2.fc10.src.rpm
snort-2.8.1-3.fc10.src.rpm
sobby-0.4.4-2.fc9.src.rpm
vinagre-2.23.3.1-1.fc10.src.rpm
virt-viewer-0.0.3-1.fc9.src.rpm
weechat-0.2.6-3.fc9.src.rpm
wireshark-1.0.0-2.fc9.src.rpm
xen-3.2.0-12.fc9.src.rpm
xenwatch-0.5.2-3.fc9.src.rpm
xmlsec1-1.2.9-10.1.src.rpm

First all the library packages must be rebuilt because the dependent
applications will not build due to the buildroot inconsistency.
I'll rebuild all the packages where it is allowed by ACLs, if you have a
package on the list above and do not want me to rebuild it even though
the ACLs allow it please send me an e-mail.

If you have any comments/objections to the version update, please
respond soon before I'll start the rebuilds - most probably on Monday if
there will be no objections.
-- 
Tomas Mraz
No matter how far down the wrong road you've gone, turn back.
                                              Turkish proverb


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]