[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FESCo Proposal for blocking older version of autoconf & automake



On 05/06/2008 01:08 PM, Steve Grubb wrote:
On Tuesday 06 May 2008 11:02:33 Christopher Aillon wrote:
he path to removing autoconf213 lies in someone patching upstream Firefox
(along with whatever other packages still uses autoconf213) to use newer
autotools and then waiting several Fedora release cycles, because this
change is almost certainly not going to happen ever in Firefox 3.  Get it
changed for Firefox 4 and when that rolls around in F13??, we can talk about
dropping it.

I agree with this. Maybe we should have a project in F10 that does the migration work so that a future Fedora can remove the old packages. About 4 years ago, I noticed a lot of redundancy and took it upon myself to migrate packages to newer tools. I was able to move all of the core packages, in about a day, off of old autoconf and automake to the current releases. I also took the liberty of moving things to bison as there was no need for byacc.

I never ran into a package that could not be ported. I did run into packages that took some effort. :)

Firefox will probably take some effort :-)

If someone with the knowledge and ambition wants to do the work, I will help as best I can. The bug once again is https://bugzilla.mozilla.org/show_bug.cgi?id=104642


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]