[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: review request for libpst



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


> I think the standard recommendation is to use a requires like this
> with
> "=", not ">=", to bind together different subpackages.  It's almost
> never a good idea to let non-matching subpackages be installed
> together
> ... unless you would like to take on the burden of testing all such
> combinations to see if they work.

But if the main executables require an exact version match to the -libs
package, then we cannot do parallel install of multiple (matching)
- -devel,-libs packages, while leaving the executables installed and
using the older version of the -libs package.

None of this matters if fedora packaging in general does not support
parallel installs. If that is the case, then yes, we can use '=' in
that Requires. 


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFJ3jnQL6j7milTFsERAgLTAJ9O7GQwvsjcEAUhk9m4ZWr6uF5t+QCbBp38
wKdcOX+0kvGPil+rpTQ8b1U=
=dbX/
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]