[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: opensync downgrade to 0.22



Rahul Sundaram wrote:
> Then, reproduce the problem and file a bug report.

Kinda pointless to file a bug report about a major design issue in a legacy
branch which is dead upstream.

Unfortunately, the OpenSync project is currently producing no production
release, there's the legacy 0.2x branch with major design issues they're
unable and/or unwilling to fix in it and no further releases are planned
from it and there's the development 0.3x/0.40 branch which is still very
broken (even more than 0.22 is).

Unfortunately, upstreams like that are a complete PITA to work with, their
software is bordering uselessness. There needs to be at least one supported
branch at any time. For libraries, application compatibility is also to be
considered (e.g. we're now stuck with no KDE 4 KitchenSync because it was
developed against 0.3x in the expectation that 0.40 would come soon as had
been promised by the OpenSync developers - it's now completely disabled in
KDE 4.2 because there's no usable libopensync for it). Libraries are
useless with no applications using them. And applications are going to be
very reluctant to port to 0.3x seeing what happened to KitchenSync.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]