[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

persistent clutter and ghc breakage (was Re: rawhide report: 20090803 changes)



>>>>> Rawhide Report  writes:

[...]

There appear to be a boatload of broken deps for packages based on
clutter (presumably because of API bump from 0.9 to 1.0) that have
been listed here for over a week and no movement to fix most of them.  

Have the other apps been ported to the new API so they just need to be
built, or have they not yet been ported?  (I tried to find an update
of cluttermm to 1.0 but only 0.9 versions are on the gnome site).  

If the latter, it would be nice the maintainer of clutter did an
inventory of dependent-packages and co-ordinate with downstream
consumers of clutter to make sure that there was a plan to update
those packages, or built a compat- package if necessary.  Otherwise
users of rawhide are left with huge swathe of breakage:

> Broken deps for i386
> ----------------------------------------------------------
> 	clutter-cairomm-0.7.4-2.fc11.i586 requires libclutter-cairo-0.8.so.0
> 	clutter-cairomm-0.7.4-2.fc11.i586 requires libcluttermm-0.8.so.2
> 	clutter-cairomm-0.7.4-2.fc11.i586 requires libclutter-glx-0.8.so.0
> 	clutter-cairomm-devel-0.7.4-2.fc11.i586 requires pkgconfig(cluttermm-0.8)
> 	clutter-cairomm-devel-0.7.4-2.fc11.i586 requires pkgconfig(clutter-0.8)
> 	clutter-gtkmm-0.9.4-1.fc12.i586 requires libclutter-gtk-0.9.so.0
> 	clutter-gtkmm-0.9.4-1.fc12.i586 requires libclutter-glx-0.9.so.0
> 	clutter-gtkmm-devel-0.9.4-1.fc12.i586 requires pkgconfig(clutter-gtk-0.9)
> 	cluttermm-0.9.4-1.fc12.i586 requires libclutter-glx-0.9.so.0
> 	cluttermm-devel-0.9.4-1.fc12.i586 requires pkgconfig(clutter-0.9)

> 	libchamplain-0.2.9-1.fc11.i586 requires libclutter-glx-0.8.so.0
> 	libchamplain-0.2.9-1.fc11.i586 requires libclutter-cairo-0.8.so.0
> 	libchamplain-devel-0.2.9-1.fc11.i586 requires pkgconfig(clutter-0.8)

> 	nbtk-0.16.3-5.fc12.i686 requires libclutter-glx-0.9.so.0
> 	nbtk-devel-0.16.3-5.fc12.i686 requires pkgconfig(clutter-0.9)

> 	pyclutter-0.8.2-2.fc11.i586 requires libclutter-glx-0.8.so.0
> 	pyclutter-cairo-0.8.2-2.fc11.i586 requires libclutter-cairo-0.8.so.0
> 	pyclutter-cairo-0.8.2-2.fc11.i586 requires libclutter-glx-0.8.so.0
> 	pyclutter-gst-0.8.2-2.fc11.i586 requires libclutter-gst-0.8.so.0
> 	pyclutter-gst-0.8.2-2.fc11.i586 requires libclutter-glx-0.8.so.0
> 	pyclutter-gtk-0.8.2-2.fc11.i586 requires libclutter-glx-0.8.so.0
> 	pyclutter-gtk-0.8.2-2.fc11.i586 requires libclutter-gtk-0.8.so.0

Similarly with ghc based packages, there appears to be no movement to
fix these broken deps:

> 	ghc-HTTP-devel-4000.0.6-3.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-HTTP-devel-4000.0.6-3.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-HTTP-doc-4000.0.6-3.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-HTTP-doc-4000.0.6-3.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-HTTP-prof-4000.0.6-3.fc12.i586 requires ghc-prof = 0:6.10.3
> 	ghc-ghc-paths-devel-0.1.0.5-7.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-ghc-paths-devel-0.1.0.5-7.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-ghc-paths-doc-0.1.0.5-7.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-ghc-paths-doc-0.1.0.5-7.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-ghc-paths-prof-0.1.0.5-7.fc12.i586 requires ghc-prof = 0:6.10.3
> 	ghc-haskell-src-exts-devel-1.0.1-1.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-haskell-src-exts-devel-1.0.1-1.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-haskell-src-exts-doc-1.0.1-1.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-haskell-src-exts-doc-1.0.1-1.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-haskell-src-exts-prof-1.0.1-1.fc12.i586 requires ghc-prof = 0:6.10.3
> 	ghc-uniplate-devel-1.2.0.3-4.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-uniplate-devel-1.2.0.3-4.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-uniplate-doc-1.2.0.3-4.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-uniplate-doc-1.2.0.3-4.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-uniplate-prof-1.2.0.3-4.fc12.i586 requires ghc-prof = 0:6.10.3
> 	ghc-zlib-devel-0.5.0.0-9.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-zlib-devel-0.5.0.0-9.fc12.i586 requires ghc = 0:6.10.3
> 	ghc-zlib-doc-0.5.0.0-9.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-zlib-doc-0.5.0.0-9.fc12.i586 requires ghc-doc = 0:6.10.3
> 	ghc-zlib-prof-0.5.0.0-9.fc12.i586 requires ghc-prof = 0:6.10.3

I must be a broken record on this, but it would be nice if maintainers
could make announcements to all concerned (e.g. on
fedora-devel-announce) about API/soname etc. bumps in major
libraries/frameworks *before* they are put into motion so that the
dependent packages can be rebuilt in a timely manner.  Or if that
causes too much breakage where, for example, many apps aren't ready to
be ported to the new version, then consider delaying the update for a
while or introducing compat- packages.

Otherwise breakage goes on for weeks and necessitating a rush to
rebuild the software by provenpackagers just before a freeze which
leaves an inadequate time for user/developer testing on rawhide.

Thanks,
Alex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]